Início / Algoritmos / Crie um algoritmo que receba 4 notas de um aluno. Calcule a média e exiba se esta aprovado ou reprovado utilizando conceitos A, B e C aprovado e D e E reprovado

Crie um algoritmo que receba 4 notas de um aluno. Calcule a média e exiba se esta aprovado ou reprovado utilizando conceitos A, B e C aprovado e D e E reprovado

Conceitos:

A: ≥ 9
B: ≥ 7 e < 9
C: ≥ 5 e < 7
D: ≥ 2,5 e < 5
E: < 2,5

D e E – Reprovado.

Pseudocódigo:

programa exercicio17
var
   n1, n2, n3, n4, media : real;
inicio
   leia n1;
   leia n2;
   leia n3;
   leia n4;
   media ← (n1 + n2 + n3 + n4) / 4; 
   se (media >= 9) entao
       escreva "Nota A: Aluno Aprovado"
   senao
     se (media >= 7) e (media < 9) entao
        escreva "Nota B: Aluno AprovadoB"
     senao
        se (media >= 5) e (media < 7) entao
            escreva "Nota C: Aluno Aprovado"
        senao
          se (media >= 2,5) e (media <= 5) entao
              escreva "Nota D: Aluno Reprovado"
          senao
              se (media < 2,5) entao
                  escreva "Nota E: Aluno Reprovado"
              fim_se;
          fim_se;
        fim_se; 
     fim_se;
   fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 14/04/2010
Program exercicio1;
 uses crt;
 var
 n1, n2, n3, n4, media : real;
 Begin
 writeln('Insira Nota 1');
 readln(n1);
 writeln('Insira Nota 2');
 readln(n2);
 writeln('Insira Nota 3');
 readln(n3);
 writeln('Insira Nota 4');
 readln(n4); 
 media := (n1 + n2 + n3 + n4) / 4;
 	if (media >= 9) then
	 writeln('Nota A: Aluno Aprovado')
	else
		if (media >= 7) and (media < 9) then
			writeln('Nota B: Aluno Aprovado')
		else
			if (media >= 5) and (media < 7) then
				writeln('Nota C: Aluno Aprovado')
			else
				if (media >= 2.5) and (media < 5) then
					writeln('Nota D: Aluno Reprovado')
				else
					if (media < 2.5) then
						writeln('Nota E: Aluno Reprovado');
 writeln('Media = ', media:4:2);
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …