Início / Algoritmos / Crie um programa que receba um valor inteiro e identifique se o mesmo é par ou ímpar

Crie um programa que receba um valor inteiro e identifique se o mesmo é par ou ímpar

Pseudocódigo:

programa exercicio6
var
  n, resto : inteiro;
inicio
   leia n;
   resto ← n mod 2;
   se (resto = 0) entao
     escreva "Número Par" 
   senao
     escreva "Número Ímpar"; 
   fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 25/03/2010
Program exercicio6;
 uses crt;
 var
 n, resto : integer;
 Begin
 writeln('Insira um Numero inteiro');
 readln(n);
 resto := N mod 2;
 	if (resto = 0) then
 	  writeln('Número Par')
 	  else
 	  	writeln('Número Impar');
 writeln('Pressione para fechar');
 readkey;  
End.

Teste de Mesa:

6/2 = 3 resto 0 – Par
5/2 = 2 resto 1 – Ímpar

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …