Início / Algoritmos / Ler um nome e o sexo de uma pessoa e se esse sexo for feminino apresentar em tela prezada e o nome e se for masculino apresentar prezado e o nome.

Ler um nome e o sexo de uma pessoa e se esse sexo for feminino apresentar em tela prezada e o nome e se for masculino apresentar prezado e o nome.

Pseudocódigo:

programa exercicio12
var
  nome, sexo : caractere;
inicio
   leia nome;
   leia sexo;
   se (sexo = "F") ou (sexo = "f") entao
     escreva "Prezada" + nome;
   senao
	escreva "Prezado" + nome;
   fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 20/03/2014
Program exercicio12;
 uses crt;
 var
 nome, sexo : string;
 Begin
 writeln('Insira o Nome');
 readln(nome);
 writeln('Escolha o sexo. Ex. F (Feminino) M (Masculino)');
 readln(sexo);
 	if (sexo = 'F') or (sexo = 'f') then
 	  writeln('Prezada ', nome)
 	  else
 	  	writeln('Prezado ', nome);
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …