Algoritmos

Algoritmo que apresente as potências de 3 variando de 0 a 15

Curta Nossa Página

Pseudocódigo:

programa exercicio5
var
   inteiro: base, potencia;
   real : resultado;
inicio
escreva "Potencia de 3: De 0 a 15";
base ← 3;
	para potencia de 0 ate 15 passo 1 faça
		resultado ← base ** potencia;
		escreva (base, " ** ", potencia, ' = ', resultado);
	fim_para;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 12/05/2010
Program exercicio5;
 uses crt, math;
 var
  base, potencia : integer;
  resultado : real;
 Begin
 writeln('Potencia de 3: De 0 a 15');
 writeln;  
 base := 3;
 	for potencia := 0 to 15 do
 		begin
 			resultado := (exp (potencia*ln(base)));
 			writeln(base, ' ** ', potencia, ' = ', resultado:3:0);
 		end;
 writeln('Pressione para fechar');
 readkey;  
End.

Etiquetas

Artigos relacionados

Botão Voltar ao topo

Adblock detectado

Por favor, considere apoiar-nos, desativando o seu bloqueador de anúncios