Início / Algoritmos / Dado um número inteiro positivo (base 10), construa um algoritmo para transformá-lo em binário

Dado um número inteiro positivo (base 10), construa um algoritmo para transformá-lo em binário

Pseudocódigo:

programa exercicio6
var
   inteiro: numero, decimal;
   caractere : binario;
inicio
escreva "Insira um numero inteiro";
leia (numero);
decimal ← numero;
	enquanto (numero > 0) faça
		se (numero mod 2 = 0) então
			binario ← "0" + binario;
				senão
					binario ← "1" + binario;
		fim_se;
			numero ← numero div 2;
	fim_enquanto;
escreva ("O numero ", decimal, "em binario = ", binario);
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 12/05/2010
Program exercicio6;
 uses crt;
 var
  numero, decimal : integer;
  binario : string;
 Begin
 writeln('Insira um numero inteiro');
 readln(numero);
 decimal := numero;
	while (numero > 0) do
		begin
			if (numero mod 2 = 0) then
				binario := '0' + binario
				else
					binario := '1' + binario;
			numero := numero div 2;
		end;
		writeln('O numero ', decimal, ' em binario = ', binario);
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …