Início / Algoritmos / Dados três valores A,B e C verifique se eles podem ser os comprimentos dos lados de um triângulo e se forem verificar se compõe um triângulo equilátero, isósceles a escaleno ou nenhum triângulo

Dados três valores A,B e C verifique se eles podem ser os comprimentos dos lados de um triângulo e se forem verificar se compõe um triângulo equilátero, isósceles a escaleno ou nenhum triângulo

Pseudocódigo:

programa exercicio9
var
  a, c, c : real;
inicio
  leia a;
  leia b;
  leia c;
  se (a < b + c) e (b < a + c) e (c < a + b) entao
   se (a = b) e (b = c) entao
    escreva "Triangulo Equilatero"
   senao
     se (a = b) ou (a = c) ou (c = b) entao
      escreva "Triangulo Isosceles"
     senao
       escreva "Triangulo Escaleno"
senao 
 escreva "As medidas nao formam triangulo";
     fim_se;
   fim_se;
  fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 08/04/2010
Program exercicio9;
 uses crt;
 var
 a, b, c : real;
 Begin
 writeln('Insira valor de A');
 readln(a);
 writeln('Insira valor de B');
 readln(b);
 writeln('Insira valor de C');
 readln(c);  
 	if (a < b + c) and (b < a + c) and (c < a + b) then
 	  if (a = b) and (b = c) then
 	  	writeln('Triangulo Equilatero')
 	  	else
 	  		if (a = b) or (a = c) or (c = b) then
 	  			writeln('Triangulo Isosceles')
 	  			else
 	  				writeln('Triangulo Escaleno')
 	else
 		writeln('As medidas nao formam triangulo');
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …