Início / Algoritmos / Elaborar um algoritmo que dada a idade de um nadador, classifique-o em um das categorias. Infantil A, Infantil B, Juvenil A, Juvenil B e Sênior

Elaborar um algoritmo que dada a idade de um nadador, classifique-o em um das categorias. Infantil A, Infantil B, Juvenil A, Juvenil B e Sênior

Categorias:

Infantil A: 5 a 7 anos
Infantil B: 8 a 10 anos
Juvenil A: 11 a 13 anos
Juvenil B: 14 a 17 anos
Sênior: Maior que 18 anos

Pseudocódigo:

programa exercicio15
var
   idade : inteiro;
inicio
   leia idade;
   se (idade >= 5) e (idade <= 7) entao
       escreva "Infantil A"
   senao
     se (idade >= 8) e (idade <= 10) entao
	 	escreva "Infantil B"
     senao
        se (idade >= 11) e (idade <= 13) entao
	   		escreva "Juvenil A"
        senao
	  	  se (idade >= 14) e (idade <= 17) entao
	      	  escreva "Juvenil B"
          senao
	    	  se (idade >= 18) entao
	        	  escreva "Senior"
              senao
	      		  se (idade < 5) entao
	          		  escreva "Na ha categoria";
	      		  fim_se;
              fim_se;
	      fim_se;
        fim_se;	
     fim_se;
   fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 14/04/2010
Program exercicio15;
 uses crt;
 var
 idade : integer;
 Begin
 writeln('Insira uma Idade');
 readln(idade);
 	if (idade >= 5) and (idade <= 7) then
 		writeln('Infantil A')
 	else
 		if (idade >= 8) and (idade <=10) then
 		    writeln('Infantil B')
 		else
 			if (idade >= 11) and (idade <= 13) then
 				writeln('Juvenil A')
 			else
 				if (idade >= 14) and (idade <= 17) then
 					writeln('Juvenil B')
 				else
 					if (idade > 18) then
 						writeln('Senior')
 					else
 						if (idade < 5) then
 							writeln('Na ha categoria');
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …