Início / Algoritmos / Ler dois valores numéricos inteiros e apresentar a diferença do maior valor em relação ao menor valor

Ler dois valores numéricos inteiros e apresentar a diferença do maior valor em relação ao menor valor

Pseudocódigo:

programa exercicio8
var
  diferenca, valor1, valor2 : real;
inicio
   leia valor1;
   leia valor2;
   se (valor2 > valor1) entao
     diferenca ← (valor2 - valor1);
     escreva ("A diferenca =", diferenca)
   senao
     diferenca ← (valor1 - valor2);
     escreva ("A diferenca =", diferenca);
   fim_se;
fim.

Pascal:

// Autor: Rafael Oliveira
// Data: 07/04/2010
Program exercicio8;
 uses crt;
 var
 diferenca, valor1, valor2 : real;
 Begin
 writeln('Insira um valor inteiro');
 readln(valor1);
 writeln('Insira um valor inteiro');
 readln(valor2); 
 	if (valor2 > valor1) then
 	  begin
 	  	diferenca := (valor2 - valor1);
 	  	writeln('A diferenca = ', diferenca:1:0);
 	  end
 	  else
 	  	begin
 	  		diferenca := (valor1 - valor2);
 	    		writeln('A diferenca = ', diferenca:1:0);
 	    	end;
 writeln('Pressione para fechar');
 readkey;  
End.

Verifique Também

Num certo sistema, as senhas dos usuários são representadas por um vetor de tamanho 9. Faça um algoritmo que leia uma senha e verifique se ela é válida ou não. Utilize busca binária para fazer a verificação

Vetor: U[9] = { 28, 56, 81, 39, 77, 92, 45, 19, 63 } Algoritmo …